Elabore algoritmos para os exercícios a seguir.

1) Na física, a fórmula do cálculo da Energia potencial gravitacional é dada por:

Epg = m.g.h

ou seja, Epg (Energia potencial gravitacional) = m (massa) vezez g (gravidade) vezes h (altura).

Faça um algoritmo que solicite para o usuário digitar os valores da massa (em quilogramas, valor em real), a gravidade (em valor real) e a altura (em valor inteiro). O algoritmo deve aplicar a fórmula e retornar o valor da Epg para o usuário, mostrando na tela.

Curiosidade: os professores de física usam o seguinte macete para o aluno gravar essa fórmula: Ei! Pedro, Maria gosta de homem.

1

Respostas

2014-02-18T19:23:10-03:00
// algoritmo feito em Portugol do VisuAlg.

algoritmo "Exercício"
var
     Epg, massa, gravidade : real
     altura : inteiro
inicio
     escreva("Digite o valor da massa em kg = ")
     leia(massa)
     escreva("Digite o valor da gravidade = ")
     leia(gravidade)
     escreva("Digite o valor da altura = ")
     leia(altura)
    
     Epg <- massa * gravidade * altura
    
     escreva("Energia Potencial Gravitacional = ",Epg)
    
fimalgoritmo

1 5 1
Obrigado sou meio novo, ma muito agradecidos