Escreva um algoritmo
que leia a informação de categoria (estudante, professor, idoso, outros) pelo
teclado. O algoritmo deve verificar se a pessoa tem direito a desconto de meia
entrada no cinema. O desconto de meia entrada somente não é oferecido para a
categoria outros. Informar ao usuário que a categoria não foi localizada caso
ele digite outra informação que não seja uma das 4 categorias.

1

Respostas

2014-03-18T01:48:01-03:00
algoritmo "categorias"

var
categoria : inteiro
inicio
escreval("==== CATEGORIAS ====")
escreval("1 - estudante")
escreval("2 - professor")
escreval("3 - idoso")
escreval("4 - outros")
escreval
escreva("Digite o número correspondente a categoria escolhida: ")
leia(categoria)


se ((categoria = 1) ou (categoria = 2) ou (categoria = 3) ou (categoria = 4)) entao
   se (categoria = 4) entao
      escreva("Não tem direito a desconto de meia entra")
   senao
      escreva("Tem direito a desconto de meia entra")
   fimse
senao
   escreva("A categoria não foi localizada")
fimse

fimalgoritmo