Faça um algoritmo que leia uma categoria de
trabalhador (A, B, C). Caso seja digitada uma categoria que não seja A, B, ou
C, informar “Categoria inválida”. Se a categoria for válida, ler o valor do
salário do usuário. O algoritmo deve calcular e mostrar o aumento do salário
obedecendo os critérios de aumento conforme a tabela a seguir: A – 10%, B – 15%
e C – 17%. Ao final, o algoritmo deve mostrar na tela os dados de entrada e os
dados processados

1

Respostas

2014-03-22T01:21:03-03:00
Algoritmo "Questão_03"
// Função :
// Autor : Joaquim Claro
// Data : 21/03/2014
// Seção de Declarações

var
categoria, A, B, C: inteiro

salario: real
inicio
// Seção de Comandos
escreval ("================")
escreval    ("   CATEGORIAS")
escreval ("================")

escreval
escreval (" 1 - A")
escreval (" 2 - B")
escreval (" 3 - C")
escreval

escreval("Digite o número da categoria escolhida ")
leia(categoria)
escreval("Digite o salário da categoria")
leia(salario)


se ( categoria = 1)entao
escreval("Salário final", salario * (10/100 )+ salario )
senao

se ( categoria = 2 )entao
escreval("Salário final", salario * (15/100 )+ salario )
senao

se ( categoria = 3 )entao
escreval("Salário final", salario * (17/100 )+ salario )
senao

se (categoria<>A)ou(categoria<>B)ou(categoria<>C)entao
escreval ("Categoria invalida")
fimse
fimse
fimse
fimse

fimalgoritmo

1 5 1
muito obrigado, correto o exercício vou melhorar o que eu tinha feito.
Fiz outro que ficou melhor que esse ai!
beleza amigo!
tem como posta Jclarotvm11 ?