1) (1.0 pontos) Elabore
um algoritmo que leia dois números inteiros pelo teclado. O algoritmo deve
fazer a soma dos números, mostrar o resultado e verificar e mostrar ao usuário
se o resultado da soma dos números é um número par ou impar.

Dica:

-
entrada: mostra mensagem e lê dois números.

-
processo:

- calcular o resultado da soma dos dois
números

- escrever na tela o resultado da soma

- testar

- se resultado for um número par, escrever “o
resultado da soma é um número par”


-
se resultado for um número impar, escrever “o resultado da soma é um número
impar”



a)
(1.0 ponto) Escreva o algoritmo em
estrutura simples


b)
(1.0 ponto) Escreva o algoritmo em
estrutura composta




2) Escreva um algoritmo
que leia a informação de categoria (estudante, professor, idoso, outros) pelo
teclado. O algoritmo deve verificar se a pessoa tem direito a desconto de meia
entrada no cinema. O desconto de meia entrada somente não é oferecido para a
categoria outros. Informar ao usuário que a categoria não foi localizada caso
ele digite outra informação que não seja uma das 4 categorias.

Dica:

-
entrada: mostra mensagem ao usuário e lê variável categoria

-
processo:

- testa categoria

- se categoria não for uma das 4,
escrever “categoria inválida”

- se categoria for uma das 4

- testar e escrever: “paga meia
entrada” ou “ não paga meia entrada”




a)
(1.0 ponto) Escreva o algoritmo em
estrutura simples


b)
(1.0 ponto) Escreva o algoritmo em
estrutura composta


c)
(1.0 ponto) Escreva o algoritmo em
estrutura Escolha-caso-outrocaso










3) (2.0 pontos) Faça um
algoritmo que leia uma categoria de trabalhador (A, B, C). Caso seja digitada
uma categoria que não seja A, B, ou C, informar “Categoria inválida”. Se a
categoria for válida, ler o valor do salário do usuário. O algoritmo deve
calcular e mostrar o aumento do salário obedecendo os critérios de aumento
conforme a tabela a seguir: A – 10%, B – 15% e C – 17%. Ao final, o algoritmo
deve mostrar na tela os dados de entrada e os dados processados.

Dica:

-
entrada: mostra mensagem e lê categoria.

-
processo:

- testa categoria.

- se categoria não for A, B ou C,
escrever “categoria inválida”


- se categoria for A, B ou C,

-
ler salario

-
calcular aumento de acordo com a categoria

-
mostrar categoria, salario inicial e salário com aumento



a)
(1.0 ponto) Escreva o algoritmo em
estrutura simples


b)
(1.0 ponto) Escreva o algoritmo em
estrutura composta




4) Escreva um algoritmo
que leia duas notas (valor real) de um aluno, digitadas pelo teclado. O
algoritmo deve calcular a média das duas notas. Em seguida, o algoritmo deve
verificar e mostrar o conceito obtido pelo aluno, seguindo a tabela: A [entre
8,0 e 10,0], B [entre 7.0; 8,0], C [entre 6.0; 7.0], D [entre 5.0; 6.0], E
[entre 0.0; 5.0].

Dica:

-
entrada: mostra mensagem ao usuário e as duas notas

-
processo:

- calcula média

- testa categoria

- se valor entre 0.0 e 5.0, escrever:
“Conceito E” e assim sucessivamente



a)
(1.0 ponto) Escreva o algoritmo em
estrutura simples


b)
(1.0 ponto) Escreva o algoritmo em
estrutura composta


c) (1.0 ponto) escreva o algoritmo em estrutura Escolha-caso-outrocaso.

1

Respostas

2014-03-24T21:47:09-03:00
Algoritmo "Questão 01 Estrutura Simples"
// Função : Joaquim Claro
// Autor :
// Data : 20/03/2014
// Seção de Declarações
var
A, B, resultadoSoma: inteiro
   resultado: real
   resto: caractere
inicio
// Seção de Comandos

escreval("Digite o valor de A")
    leia(A)
escreval("Digite o valor de B")
    leia (B)
resultadoSoma <- (A + B)
    escreval (" o resultado da soma de ", A, " +", B, " é = ", resultadoSoma)
se resultadoSoma mod 2 = 0  entao
    escreval (" O resultado da soma é um número par")
fimse
se resultadoSoma mod 2 <> 0 entao
    escreval(" O resultado da soma é um número impar")
fimse

fimalgoritmo

    algoritmo "Questão 01 Estrutura Composta"
// Função : Joaquim Claro
// Autor :
// Data : 20/03/2014
// Seção de Declarações
var
A, B, soma, resto: inteiro

inicio
// Seção de Comandos

    escreval("Digite o valor de A")
    leia(A)
    escreval("Digite o valor de B")
    leia (B)
    soma <- (A + B)
    escreval("O resulado da Soma de ", A, " +", B, " =",soma)
   
    se(soma mod 2 = 0)entao

    escreval (" O resultado da soma é um numero par ")

    senao
    escreval("O resultado da soma é um número impar")
    fimse

fimalgoritmo