Respostas

2014-03-28T19:01:47-03:00
// Olá, este algoritmo está no português estruturado do VisuAlg.

algoritmo "Fibonacci"
var
      i, numAnterior, numAtual, numNovo : inteiro
inicio
      i <- 2
      escreva("Escreva o 1º número: ")
      leia(numAnterior)
      escreva("Escreva o 2º número: ")
      leia(numAtual)
      escreval(numAnterior)
      escreval(numAtual)

      enquanto (i <> 20) faca
         numNovo <- numAtual + numAnterior
         numAnterior <- numAtual
         numAtual <- numNovo
         escreval(numNovo)
         i <- i + 1
      fimenquanto
fimalgoritmo