Problema com algoritmo

quando vou testar meu algoritmos da um erro na linha 12 dizendo que esperava o comando ENTAO, sendo que ele ja esta la

algoritmo "sexo"
//Função : informar o sexo
// Autor : Vinicius Soares
// Data : 01/04/2014

// Seção de Declarações
var
sexo:caractere

inicio
// Seção de Comandos
escreva("Informe seu sexo (H/M):")
leia(sexo)
se sexo<>h ou sexo<>m entao
escreval("Informe somente H ou M!")e
screva("Informe seu sexo (H/M):")
leia(sexo)
fimse
se sexo=h entao
escreva("Seu sexo é MASCULINO")
senao
escreva("Seu sexo é FEMININO")
fimse
fimalgoritmo

1

Respostas

A melhor resposta!
2014-04-01T20:49:50-03:00
// Amigo o erro é que você esqueceu de colocar a expressão entre parênteses, e
//colocar as aspas no "m" e no "h" e também você terá que usar o E em lugar do OU.


algoritmo "sexo"
var
     sexo:caractere
inicio
     escreva("Informe seu sexo (H/M):")
     leia(sexo)
         se ((sexo <> "h") e (sexo <> "m")) entao
             escreval("Informe somente H ou M!")
             escreva("Informe seu sexo (H/M):")
             leia(sexo)
         fimse
     se (sexo = "h") entao
escreva("Seu sexo é MASCULINO")
senao
escreva("Seu sexo é FEMININO")
fimse
fimalgoritmo

1 5 1