Desenvolva um algoritmo que dado um número inteiro, exiba um triangulo reto com a base formada por um número de asteriscos igual ao número informado. Exemplo: número = 8...
********
*******
******
*****
****
***
**
*

1
Em qual linguagem de programação ?
VisualG

Respostas

A melhor resposta!
2014-04-29T13:25:50-03:00
// Em português estruturado do Visualg fica assim:

algoritmo "triangulo"
var  base, i, j : inteiro
inicio
      escreva("Numero: ")
      leia(base)
     
      para  i de base ate 1 passo -1 faca
        para j de i ate 1 passo -1 faca
            escreva("*")
        fimpara
        escreval
      fimpara
fimalgoritmo





//    Em linguagem de programação C, fica assim:

#include <stdio.h>
main()
{
      int base, i, j;

      printf("Numero: ");
      scanf("%d", &base);

      for( i=base; i>=1; i-- )
      {
           for( j=i; j>=1; j-- )
           {
                printf("*");
           }
        printf("\n");
      }
}


1 5 1