Respostas

2014-05-17T12:26:52-03:00
Ex: contar de 1 ate 10.

var
j : inteiro

inicio

para J de 1 ate 10 faca 

escreva (J)
fimpara

fimalgoritmo
  • Usuário do Brainly
2014-05-17T13:10:59-03:00
Letícia, o para pode ser usado para qualquer aplicação qual você sabe uma condição de parada.

Ex:
var
i :inteiro             i é um auxiliar 
nome :caractere
inicio
para i de 1 até 5 faca
leia (nome)
fimpara
fimalgoritmo

Ou seja, ele lerá 5 nomes... ele fará o loop 5 vezes, quando atingir o número 5 ele sai do loop.

Outro exemplo
Eu tenho uma matriz e devo ler todas suas casas, crie um algoritmo para ler uma matriz 3x3

var 
i, j :inteiro
vetor[1..3,1..3] de real        ⇒ Assim foi criado a matriz em visualg 3x3
inicio
para i de 1 até 3 faca
   para j de 1 até 3 faca
leia (vetor[i,j])
fimpara
fimalgoritmo

Assim ele fará a leitura de todas as casas, fazendo um rastreamento teríamos...
para o valor 1 ele faria 1,1 1,2 1,3 para o 2 ele fará 2,1 2,2 2,3 e assim por diante até chegar no 3,3.