Alguém poderia me ajudar?...
Desenvolver um algoritmo com base em um depósito bancário de R$ X, na poupança com Rendimento de x % ao dia, faça exibir o valor atualizado com valor
do dia anterior + rendimento atual para
cada dia, durante os 30 dias do mês.



Obs.: 1 - Quando o deposito for R$ 100,00 e o rendimento for 1% ao dia, o valor do rendimento
será de R$ 1,00 e somado ao depósito teremos no dia, o valor de R$
101,00. No dia seguinte o deposito vale R$ 101,00 com rendimento 1% ao dia.
2 - Utilizar estrutura de
loop para exibição diária

Eu desenvolvi esse algoritmo (no visualg):
algoritmo "estrutura_com_loop"
// Função :
// Autor :
// Data : 17/05/2014
// Seção de Declarações
var
i:inteiro
dep,porc,rendimento:rea
linicio
// Seção de Comandos
para i de 0 ate 30 faca
escreva("Digite o valor do depósito:R$")
leia(dep)
Escreva ("Digite a porcentagem de rendimento:%")
leia(porc)
para i de 0 ate 1 faca
rendimento <- dep+dep*(porc/100)
escreval("O valor do rendimento diário é:R$",rendimento)
FIMPARA
FIMPARA
fimalgoritmo

Parece que tem algo errado, creio que deveria ser feito o cálculo pra cada dia do mês, automaticamente. Se alguém puder me ajudar ou me explicar e tals, ficarei grata!

1

Respostas

2014-05-18T16:51:48-03:00
O erro no seu código é apenas a definição da variável "real" que está escrita "rea", porém você deixou o escreval dentro dos 2 comandos para, então ele estava printando duas vezes o valor do rendimento, apenas organizei para você, aí está :)

algoritmo "estrutura_com_loop"
// Função :
// Autor :
// Data : 17/05/2014
// Seção de Declarações
var
i:inteiro
dep,porc,rendimento:real

inicio
// Seção de Comandos

escreval("Digite o valor do depósito:R$")
leia(dep)
escreval ("Digite a porcentagem de rendimento:%")
leia(porc)

para i de 1 ate 1 faca
rendimento <- dep +(dep * porc)/100

escreval("O valor do rendimento no",i , " dia é de: R$",rendimento)

fimpara

para i de 2 ate 30 faca

rendimento <- rendimento +1
escreval("O valor do rendimento no",i , " dia é de: R$",rendimento)
fimpara
fimalgoritmo
1 5 1
kkkkkk esse negócio é muito complicado, tô há 3 dias tentando resolver, só ontem que consegui um pequeno resultado e_e
Estudei isso faz tempo :D portugol é bem legal de se mecher, mas é bem enrolado, e com o tempo vc esquece x.x ja fiz facinho pra ele contar automaticamente, já te explico, mas é que ele não ta printando o primeiro valor e_e tá começando do 102 ate o 130
Atualizei a resposta :]
Deu certo :DD
Uhuu o// q