10- Elabore um algoritmo em linguagem compatível com o software VisuAlg
utilizando a estrutura ENQUANTO|FAÇA onde o usuário irá informar um
mês pelo seu número (1,2,3,4,5,6,7,8,9,10,11,12) e será retornado o
nome do mês. Quando o usuário informar um número que não pode
ser identificado como mês, deverá informar a seguinte mensagem
“NÚMERO INVÁLIDO, TENTE NOVAMENTE”.




1

Respostas

2014-06-24T02:43:49-03:00
// Prontinho!! Usei a estrutura de repetição ENQUANTO.. O programa irá
// repetir enquanto o valor da variável mes for menor que 1 ou maior que 12,
// ou seja, quando o mês for inválido. Beleza.. :)

algoritmo "exercicio"
var
    mes : inteiro
inicio
         mes <- 0
         enquanto (mes < 1) ou (mes > 12) faca
               escreval("Digite o numero referente ao mes: ")
               leia(mes)
               se (mes < 1) ou (mes > 12) entao
                   limpatela
               fimse
               escolha(mes)
                    caso 1
                          escreval("Janeiro")
                    caso 2
                          escreval("Fevereiro")
                    caso 3
                          escreval("Março")
                    caso 4
                          escreval("Abril")
                    caso 5
                          escreval("Maio")
                    caso 6
                          escreval("Junho")
                    caso 7
                          escreval("Julho")
                    caso 8
                          escreval("Agosto")
                    caso 9
                          escreval("Setembro")
                    caso 10
                          escreval("Outubro")
                    caso 11
                          escreval("Novembro")
                    caso 12
                          escreval("Dezembro")
                    outrocaso
                          escreval("Número Inválido, tente novamente.")
               fimescolha
         fimenquanto
fimalgoritmo


1 5 1