Faça um algoritmo que leia uma matriz quadrada 4x4 de valores
inteiros, mostrando no final do algoritmo os seguintes dados:
a) A soma de cada uma das linhas.


b) A soma de cada uma das colunas.


c) A soma da diagonal principal.


d) A soma da diagonal secundária.

1

Respostas

  • Usuário do Brainly
2013-08-03T05:09:15-03:00
Tente usar essa lógica:

algoritmo "semnome"
// Função :
// Autor :
// Data : 02/08/2013
// Seção de Declarações
var
Matriz: vetor [1..4 , 1..4] de inteiro
L,C: Inteiro
SomaL : Vetor [1..4] de inteiro
SomaC : Vetor [1..4] de inteiro
SomaDP: Vetor [1..2] de inteiro
SomaDS: Vetor [1..2] de inteiro
inicio
// Seção de Comandos
Para L de 1 ate 4 faca
Para C de 1 ate 4 faca
Escreval ("Dê valor à Aij ", L ,",", C)
Leia(Matriz[L,C])
fimpara
fimpara

//Soma Linhas:
Para L de 1 ate 4 faca
Para C de 1 ate 4 faca
SomaL[L] <- SomaL[L] + Matriz[L,C]
fimpara
fimpara
//Soma Colunas:
Para C de 1 ate 4 faca
Para L de 1 ate 4 faca
SomaC[C] <- SomaC[C] + Matriz[L,C]
fimpara
fimpara
//Soma Diagonal principal:
Para C de 1 ate 4 faca
SomaDP<- SomaDP + Matriz[C,C]
fimpara
//Soma Diagonal Secundária:
Para C de 1 ate 4 faca
SomaDS<- SomaDS + Matriz[C,5-C]
fimpara

//Apresentação de resultados:
Para C de 1 ate 4 faca
Escreval ("Soma da linha ", C, " : ", SomaL[C])
fimpara

Para C de 1 ate 4 faca
Escreval ("Soma da coluna ", C, " : ", SomaC[C])
fimpara

Escreval ("Soma da diagonal principal :", SomaDP)

Escreval ("Soma da diagonal secundária: ", SomaDS)




fimalgoritmo


PS: Não deu pra testar, mas acho que ajuda; 
1 2 1