Respostas

2014-08-28T16:14:48-03:00
Var
idade, i, somaT, somaF, somaM, contadorM, contadorF: inteiro;
mediaT, mediaM, mediaF: real;
sexo: caractere;

Inicio
i=0; contadorM=0; contadorF=0; somaM=0; somaF=0; somaT=0;

Para i de 1 até 10 faça
Escreva("Digite a sua idade");
Leia(idade);
 
Escreva("Digite o sexo M/F")
Leia(sexo);

Se(sexo='M') então
somaM=somaM+idade;
contadorM=contadorM+1;

Senão
somaF=somaF+idade;
contadorF=contadorF+1;

fim-se;

somaT=somaT+idade
fim-para;

mediaT= somaT/10;
mediaM= somaM/contadorM;
mediaF= somaF/contadorF;

Escreva("A idade média do grupo é", mediaT);
Escreva("A idade média do sexo masculino é", mediaM);
Escreva("A idade média do sexo feminino é", mediaF);
FIM.

1 5 1
Independentemente da linguagem a lógica está certa:.