Desenvolva um algoritmo que receba um dia da semana, verifique e mostre qual a avaliação realizada nesta data, qual o horário e o grau de dificuldade, conforme tabela abaixo:

Data| Dados
| Disciplina | Horário | dificuldade
Segunda-feira |Logica de programacao | 19h30 as 21h | médio
Terça-feira | Logica matematica | 21h30 as 23h | dificil
Quarta-feira | Fundamentos Software | 19h30 as 21h | Fácil
Quinta feira | Fundamentos de Hardware| 21h30 as 23h |fácil
Sexta | Ingles | 19h30 as 21h |Médio

1

Respostas

2013-10-25T21:14:46-02:00
Algoritmo "Tabela"
// Função :
// Autor : Danielsilva
// Data : 25/10/2013
// Seção de Declarações 
var
semana: vetor [0..4,0..3] de caractere
i,j:inteiro
dia_semana:inteiro
inicio
escreval("Digite:")
para i de 0 ate 4 faca
    escreval(i," para ",semana[i,0])
fimpara
leia(dia_semana)
semana[0,0]:="Segunda - feira"
semana[0,1]:="Logica de programacao"
semana[0,2]:="19h30 as 21h"
semana[0,3]:="médio"
semana[1,0]:="Terça-feira "
semana[1,1]:="Logica matematica"
semana[1,2]:="21h30 as 23h"
semana[1,3]:="dificil"
semana[2,0]:="Quarta-feira"
semana[2,1]:="Fundamentos Software"
semana[2,2]:="19h30 as 21h"
semana[2,3]:="Fácil"
semana[3,0]:="Quinta feira"
semana[3,1]:="Fundamentos de Hardware"
semana[3,2]:="21h30 as 23h"
semana[3,3]:="fácil"
semana[4,0]:="Sexta"
semana[4,1]:="Ingles"
semana[4,2]:="19h30 as 21h"
semana[4,3]:="Médio"

para i de 0 ate 4 faca
    se semana[dia_semana,0]=semana[i,0] entao
        escreval("Data | Disciplina | horário | dificuldade") 
      para j de 0 ate 3 faca
        escreva(" ",semana[i,j]," ")
      fimpara
   senao
     //  interrompa
   fimse
fimpara

fimalgoritmo