Escreva um algoritmo que receba do teclado oito valores inteiros e
armazene em um vetor. Em seguida, o algoritmo deverá ser capaz de
ordenar os elementos do vetor, do menor para o maior, e, por fim, exibir o resultado na tela. PRECISO EM VISUAL G

1

Respostas

2013-10-28T18:17:14-02:00

Esta é uma Resposta Verificada

×
As Respostas verificadas contém informações confiáveis, garantidas por um time de especialistas escolhido a dedo. O Brainly tem milhões de respostas de alta qualidade, todas cuidadosamente moderadas pela nossa comunidade de membros, e respostas verificadas são as melhores de todas.
Algoritmo "Ordenação crescente de 1 a 8"
// Função :
// Autor :
// Data : 28/10/2013
// Seção de Declarações
var
vet: vetor[1..8] de inteiro
ind: inteiro
x: inteiro

inicio
// Seção de Comandos
para ind de 1 ate 8 faca
escreva("Informe Numero ", ind,"º numero: ")
leia(vet[ind])
fimpara

para ind de 1 ate 8 faca
se (vet[1]>vet[ind]) entao
x <- vet[1]
vet[1]<- vet[ind]
vet[ind]<- x
fimse
fimpara

para ind de 3 ate 8 faca
se (vet[2]>vet[ind]) entao
x <- vet[2]
vet[2]<- vet[ind]
vet[ind]<- x
fimse
fimpara

para ind de 4 ate 7 faca
se (vet[3]>vet[ind]) entao
x <- vet[3]
vet[3]<- vet[ind]
vet[ind]<- x
fimse
fimpara

para ind de 5 ate 8 faca
se (vet[4]>vet[ind]) entao
x <- vet[4]
vet[4]<- vet[ind]
vet[ind]<- x
fimse
fimpara

para ind de 6 ate 8 faca
se (vet[5]>vet[ind]) entao
x <- vet[5]
vet[5]<- vet[ind]
vet[ind]<- x
fimse
fimpara

se (vet[6]>vet[8]) entao
x <- vet[6]
vet[6]<- vet[8]
vet[7]<- x
fimse

escreval("ORDEM CRESCENTE: ")
para ind de 1 ate 8 faca
escreval (vet[ind])
fimpara
fimalgoritmo

testato e funcionado boa sorte!