Me ajudem! To perdidão em lógica!? Elabore uma sub-rotina que receba dois números escolha o símbolo da operação(+ ou *) efetue a adição ou multiplicação mostrando o resultado dela ao final. Desenvolva uma sub-rotina que receba um valor em uma temperatura em graus Celsius e converta em temperatura em graus Fahrenheit. No Visualg(ferramenta usada ao decorrer do curso) função ou procedimento podem receber vetores/matrizes por parâmetros? Por que?

1

Respostas

2013-04-07T23:21:43-03:00

var
a,b:real
vari: caracter

funcao calcu(x,y:real):real
var
calc: real
inicio
se (vari=("+"))entao
calc <- x+y
fimse
se (vari=("*")) entao
calc <- x*y
fimse
retorne calc
fimfuncao
inicio
Escreval ("Digite um numero")
leia(a)
Escreval ("Digite outro numero")
leia(b)
escreval ("Digite o sinal da operação (+) para soma e (*) (sem parenteses) para multiplicação")
leia(vari)
Escreval ("Resultado: ",calcu(a,b))
fimalgoritmo

1 5 1