Respostas

2013-11-21T22:01:34-02:00
Fiz usando o visualg.

var
valor : inteiro
op : inteiro

inicio
escreval("Digite o valor da compra:")
leia(valor)
escreval("Digite a forma de pagamento:")
escreval("1 - À vista 15% / 2 - 30 dias 10% / 3 - 2x %5")
leia(op)

escolha (op)
caso 1
     valor <- valor - (valor * 15/100)
caso 2
     valor <- valor - (10/100 * valor)
caso 3
     valor <- valor - (5/100 * valor)
outrocaso
         escreval("Opcao invalida...")
fimescolha
escreval("O valor a pagar e de: R$",valor)
fimalgoritmo
2 5 2