Respostas

2014-02-12T00:12:27-02:00
/* A condição para ser um triângulo é que o comprimento de cada lado de um triângulo é menor do que a soma dos outros dois lados, fora desta condição as medidas não serão consideradas de um triângulo.
Para ser um triângulo escaleno as medidas dos três lados deverão ser diferentes umas das outras. */

Algoritmo "triangulo_escaleno"
var
    lado1, lado2, lado3 : real
Inicio
       escreva("Digite o valor do lado 1: ")
       leia(lado1)
       escreva("Digite o valor do lado 2: ")
       leia(lado2)
       escreva("Digite o valor do lado 3: ")
       leia(lado3)
Se((lado1<(lado2+lado3))e(lado2<(lado1+lado3))e(lado3<(lado1+lado2)))entao
     Se (lado1 <> lado2) e (lado1 <> lado3) e (lado3 <> lado2)entao
         escreva("Triângulo Escaleno")
     Senao
         escreva("Triângulo não é Escaleno")
     fimse
  Senao
    escreva("Não é um triângulo")
  fimse
fimalgoritmo

// Algoritmo desenvolvido no VisuAlg.


1 5 1