1) faça um programa que receba o código correspondente ao cargo de um funcionário e seu salario atual e apresenta o nome do cargo, o valor do aumento e seu novo salario. Os cargos estão na tabela abaixo.

CÓDIGO CARGO PERCENTUAL
1 escritório 50%
2 secretario 35%
3 caixa 20%


2) Crie um algoritmo que realize as seguintes atividades:
- Solicite ao usuário três valores inteiros
- Multiplique o menor valor lido pelo maior e some o resultado com valor do meio.
- Imprima na tela o resultado.


OBS: FAZER DA MANEIRA MAIS SIMPLES POSSÍVEL POIS AINDA SOU INICIANTE...VALEU DESDE JÁ OBRIGADO...


1

Respostas

2014-02-16T22:46:39-03:00

Esta é uma Resposta Verificada

×
As Respostas verificadas contém informações confiáveis, garantidas por um time de especialistas escolhido a dedo. O Brainly tem milhões de respostas de alta qualidade, todas cuidadosamente moderadas pela nossa comunidade de membros, e respostas verificadas são as melhores de todas.
// Olá Natan, esse primeiro exercício fiz no VisuAlg - Portugol.
algoritmo "Exercicio1"

Var
    salario, aumento : real
    cargo : inteiro

inicio
     escreval("Tabela de Cargos")
     escreval("1 - Escritório")
     escreval("2 - Secretário")
     escreval("3 – Caixa")
     escreva("Digite o número correspondente ao cargo do funcionário: ")
     leia(cargo)
     escreva("Digite o salário atual: ")
     leia(salario)

       escolha cargo
        caso 1
            aumento <- salario * 0.5
              escreval("O cargo escolhido foi: Escritorio")
        caso 2
            aumento <- salario * 0.35
              escreval("O cargo escolhido foi: Secretario")
        caso 3
            aumento <- salario * 0.2
              escreval("O cargo escolhido foi: Caixa")
        outrocaso
            escreval("Você digitou errado o número de correspondente ao cargo!")
        fimescolha
      se ((cargo >= 1) e (cargo <= 5)) entao
        escreval("O novo salário é: ",(salario + aumento))
        escreva("O valor do aumento é: ",aumento)
      fimse

fimalgoritmo





/*
(Exercício 2)
Esse algoritmo foi feito na linguagem C, você pode compilar ele no DEV-C++.
OBS: Fiz este algoritmo em C, porque não sei fazer alguns algoritmos no Visual,
sou iniciante também e estou aprendendo algoritmos no C.
*/

#include <stdio.h>
#include <conio.h>
#include <windows.h>
main()
{
     int n1, n2, n3, resultado;
    
     printf("Digite o numero 1: ");
     scanf("%d",&n1);
     printf("Digite o numero 2: ");
     scanf("%d",&n2);
     printf("Digite o numero 3: ");
     scanf("%d",&n3);
    
     if ((n1 > n2) && (n1 > n3) && (n2 > n3))
        resultado = (n1 * n3 + n2);
     else if ((n1 > n2) && (n1 > n3) && (n3 > n2))
        resultado = (n1 * n2 + n3);
     else if ((n2 > n1) && (n2 > n3) && (n1 > n3))
        resultado = (n2 * n3 + n1);
     else if ((n2 > n1) && (n2 > n3) && (n3 > n1))
        resultado = (n2 * n1 + n3);
     else if (n1 > n2)
        resultado = (n3 * n2 + n1);
     else
        resultado = (n3 * n1 + n2);
    
     printf("Resultado: %d\n",resultado);
     system("pause");
}
// espero ter ajudado!


2 5 2
O primeiro já está pronto, você pode rodar ele no VisuAlg 2.0
Você queria o primeiro na linguagem C ?
sim pois desta maneira ainda não cheguei, estou no segundo ano de algoritmo, em um curso técnico em informatica IFPR.
Já mandei pra sua caixa de mensagens duas formas de resolver o exercício 1. Eles estão na linguagem C. Em um eu usei o case (CASO) e no outro eu usei o if, else (SE, SENÃO).
beleza obrigado mesmo