Respostas

2014-03-03T15:09:05-03:00
inicio
    para i de 0 até 10 passo 1 faca
        escreva(i);
        se i = 5 entao
            escreva("cinco")
        fimse
    fimpara
fimalgoritmo 

Não entendi se deveria ler 10 valores além de imprimir, porém, você poderá adicionar esta linha após o escreva(i):
inicio
    para i de 0 até 10 passo 1 faca
        escreva(i);
        leia(numero)
        escreva(numero)
        se i = 5 entao
            escreva("cinco")
        fimse
    fimpara
fimalgoritmo 

Supimpa???