Faça um algoritmo que leia uma categoria de trabalhador (A, B, C). Caso seja digitada uma categoria que não seja A, B, ou C, informar “Categoria inválida”. Se a categoria for válida, ler o valor do salário do usuário. O algoritmo deve calcular e mostrar o aumento do salário obedecendo os critérios de aumento conforme a tabela a seguir: A – 10%, B – 15% e C – 17%. Ao final, o algoritmo deve mostrar na tela os dados de entrada e os dados processados.

1

Respostas

2014-03-22T12:04:22-03:00
Va
r salario, a, b,c: real
 categoria: real
 inicio // Seção de Comandos escreval
 ("escreva o numero correspondente da categoria")
escreval ("1 categoria A")
 escreval ("2 categoria B")
 escreval ("3 categoria C")
leia (categoria )
se (categoria< 1) ou(categoria> 3) entao
 escreval ("categoria invalida")
 fimse se
(categoria= 1) entao
 escreval ("digite o salario da categoria A")
 leia(a)
salario<-a+a*0.1
 escreval ("o valor recebido em salario pela cat A acrescido de 10% R$:",salario)
 fimse se
(categoria= 2) entao escreval ("digite o salario da categoria B")
 leia(b)
 salario<-b+b*0.15
 escreval ("o valor recebido em salario pela cat B acrescido de 15% R$:",salario)
 fimse se
(categoria= 3) entao
 escreval ("digite o salario da categoria C")
 leia(c)
 salario<-c+c*0.17
 escreval ("o valor recebido em salario pela cat C acrescido de 17% R$:",salario)
 fimse
 fimalgoritmo  



estrutura simples sem o a utilizaçao do senao, ok!!