4) Escreva um algoritmo que leia duas notas (valor real) de um aluno, digitadas pelo teclado. O algoritmo deve calcular a média das duas notas. Em seguida, o algoritmo deve verificar e mostrar o conceito obtido pelo aluno, seguindo a tabela: A [entre 8,0 e 10,0], B [entre 7.0; 8,0], C [entre 6.0; 7.0], D [entre 5.0; 6.0], E [entre 0.0; 5.0].

Dica:

- entrada: mostra mensagem ao usuário e as duas notas

- processo:

- calcula média

- testa categoria

- se valor entre 0.0 e 5.0, escrever: “Conceito E” e assim sucessivamente

a) (1.0 ponto) Escreva o algoritmo em estrutura simples

b) (1.0 ponto) Escreva o algoritmo em estrutura composta

c) (1.0 ponto) Escreva o algoritmo em estrutura Escolha-caso-outrocaso

.

1

Respostas

A melhor resposta!
2014-03-22T11:55:57-03:00
Var n1,n2,media:
real
 inicio // Seção de Comandos
 escreval ("nota")
 leia (n1)
escreval ("segunda nota")
 leia (n2)
media<-(n1+n2)/2
 escreval ("o resultado da media é igual a:", media)
 escolha media
 caso 0 ate 5
 escreval ("conceito E")
 caso 5 ate 6
 escreval ("conceito D")
 caso 6 ate 7
 escreval ("conceito C") caso 7 ate 8 escreval ("conceito B")
 caso 8 ate 10
 escreval ("conceito A")
 outrocaso escreval ("opçao invalida")
 fimescolha
 fimalgoritmo  

eae galera, espero ter ajudado



2 4 2