2) Escreva um algoritmo
que leia a informação de categoria (estudante, professor, idoso, outros) pelo
teclado. O algoritmo deve verificar se a pessoa tem direito a desconto de meia
entrada no cinema. O desconto de meia entrada somente não é oferecido para a
categoria outros. Informar ao usuário que a categoria não foi localizada caso
ele digite outra informação que não seja uma das 4 categorias.

Dica:

-
entrada: mostra mensagem ao usuário e lê variável categoria

-
processo:

- testa categoria

- se categoria não for uma das 4,
escrever “categoria inválida”

- se categoria for uma das 4

- testar e escrever: “paga meia
entrada” ou “ não paga meia entrada”




a)
(1.0 ponto) Escreva o algoritmo em
estrutura simples


b)
(1.0 ponto) Escreva o algoritmo em
estrutura composta


c)
(1.0 ponto) Escreva o algoritmo em
estrutura Escolha-caso-outrocaso

1
Bom agora é só trabalhar pra fazer a estrutura composta, moleza!!!

Respostas

2014-03-23T00:09:50-03:00
Algoritmo "Questão _02_estrura_simples"
// Função :
// Autor : Joaquim Claro- Polo de Lucas IFMT
// Data : 21/03/2014
// Seção de Declarações

var
categoria, estudante, professor, idoso, outros : literal
inicio
escreval("==== CATEGORIAS ====")
escreval("====================")
escreval("estudante")
escreval("professor")
escreval("idoso")
escreval("outros")
escreval
escreval("Digite a categoria escolhida: ")
leia(categoria)


se (categoria = ("estudante"))entao
escreval("Tem direito a desconto de meia entrada")

senao
se (categoria = ("professor"))entao
escreval("Tem direito a desconto de meia entrada")

senao
se(categoria = ("idoso")) entao
escreval("Tem direito a desconto de meia entrada")

senao
se(categoria = ("outros")) entao
escreval("Não tem direito a desconto de meia entrada")

senao
se(categoria<>("estudante"))ou(categoria<>("professor"))ou(categoria<>("idoso"))ou (categoria<>("outros"))entao

escreval("Categoria inválida")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo