Elabore um algoritmo
que leia dois números inteiros pelo teclado. O algoritmo deve fazer a soma dos
números, mostrar o resultado e verificar e mostrar ao usuário se o resultado da
soma dos números é um número par ou impar.

Dica:

-
entrada: mostra mensagem e lê dois números.

-
processo:

- calcular o resultado da soma dos dois
números

- escrever na tela o resultado da soma

- testar

- se resultado for um número par, escrever “o
resultado da soma é um número par”


-
se resultado for um número impar, escrever “o resultado da soma é um número
impar”



a) Escreva o algoritmo em
estrutura simples



b) Escreva o algoritmo em
estrutura composta

1
O que você quis dizer com estrutura simples e composta? E em que linguagem?

Respostas

2014-03-23T00:06:34-03:00
Algoritmo "Questão 01 Estrutura Simples"
// Função :
// Autor : Joaquim Claro  polo de Lucas - IFMT
// Data : 20/03/2014
// Seção de Declarações
var
A, B, resultadoSoma: inteiro
   resultado: real
   resto: caractere
inicio
// Seção de Comandos

escreval("Digite o valor de A")
    leia(A)
escreval("Digite o valor de B")
    leia (B)
resultadoSoma <- (A + B)
    escreval (" o resultado da soma de ", A, " +", B, " é = ", resultadoSoma)
se resultadoSoma mod 2 = 0  entao
    escreval (" O resultado da soma é um número par")
fimse
se resultadoSoma mod 2 <> 0 entao
    escreval(" O resultado da soma é um número impar")
fimse

fimalgoritmo