Respostas

2014-03-28T14:59:11-03:00

Esta é uma Resposta Verificada

×
As Respostas verificadas contém informações confiáveis, garantidas por um time de especialistas escolhido a dedo. O Brainly tem milhões de respostas de alta qualidade, todas cuidadosamente moderadas pela nossa comunidade de membros, e respostas verificadas são as melhores de todas.
// Essa é uma forma bem simples. Mas você tem que saber sobre VETORES e LAÇOS // DE REPETIÇÃO, pois foi o que eu usei para fazer o algoritmo.
// Se eu não fizesse com vetores e laços de repetição o algoritmo iria ficar "imenso".


algoritmo "exercicio"
var numero : vetor[1..20] de inteiro
    i, maior, menor : inteiro
inicio
       maior <- 0
       escreva("Digite o 1º número: ")
       leia(numero[1])
       menor <- numero[1]
       Para i de 2 ate 20 faca
          escreva("Digite o",i,"º número: ")
          leia(numero[i])
             se numero[i] < menor entao
                menor <- numero[i]
             fimse
             se numero[i] > maior entao
                maior <- numero[i]
             fimse
       fimpara
       escreval("O maior número: ",maior)
       escreva("O menor número: ", menor)
fimalgoritmo

1 5 1