Escreva um algoritmo que solicite ao usuário três valores correspondentes aos três ângulos de um triangulo :

A. O algoritmo devera validar se a soma dos três ângulos é igual a 180.

B. Se a soma for igual a 180, o algoritmo devera informar se o triangulo é retângulo, acutângulo

Se possivel ser resolvido pelo visualg

1

Respostas

2014-04-16T16:26:11-03:00
algoritmo "triangulo"

var A, B, C : inteiro

inicio
    escreva("Digite o valor do ângulo A: ")
    leia(A)
    escreva("Digite o valor do ângulo B: ")
    leia(B)
    escreva("Digite o valor do ângulo C: ")
    leia(C)

    se ((A + B + C) = 180) entao
       escreval("É um triângulo! Pois a soma dos ângulos é igual a 180.")
       se ( (A = 90) ou (B = 90) ou (C = 90) ) entao
           escreva("Triângulo Retângulo!")
       senao
           se ( (A < 90) e (B < 90) e (C < 90) ) entao
              escreva("Triângulo Acutângulo!")
           senao
              escreva("Triângulo Obtusângulo!")
           fimse
       fimse
    senao
       escreva("Não é um Triângulo!")
    fimse
fimalgoritmo

2 4 2
Muito obrigado Joinersa ajudou muito.