Converta para C a linguagem em portugool abaixo:
algoritmo L4P19;

var

inteiro: C, CODSEXO,
NMULHER;


real: ALTURA, MAIOR,
MENOR;


real: VETALT[1..50],
VETSEX[1..50];


real: SOMAMULHER,
MEDIAMULHER;


real: SOMATURMA,
MEDIATURMA;


início

para C de 1 até 50
faça


leia(ALTURA);

leia(CODSEXO);

VETALT[C] <-
ALTURA;


VETSEX[C] <-
CODSEXO;


fim-para

NMULHER <- 0;

SOMAMULHER <- 0;

SOMATURMA <- 0;

MAIOR <-
VETALT[1];


MENOR <-
VETALT[1];


para C de 1 até 50
faça


se ( VETALT[C] >
MAIOR ) então


MAIOR <-
VETALT[C];


senão

se ( VETALT[C] <
MENOR ) então


MENOR <-
VETALT[C];


fim-se

fim-se

se ( VETSEX[C] = 2 )
então


NMULHER <- NMULHER
+ 1;


SOMAMULHER <-
SOMAMULHER + VETALT[C];


fim-se

SOMATURMA <-
SOMATURMA + VETALT[C];


fim-para

MEDIAMULHER <-
SOMAMULHER / NMULHER;


MEDIATURMA <-
SOMATURMA / 50;


imprima("Maior
altura da turma: ",MAIOR);


imprima("Menor
altura da turma: ",MENOR);


imprima("Mulheres com altura acima da
media das mulheres");


para C de 1 até 50
faça


se ( VETSEX[C] = 2 )
e ( VETALT[C] > MEDIAMULHER ) então


imprima(VETALT[C]);

fim-se

fim-para

imprima("Pessoas
com altura abaixo da media");


para C de 1 até 50
faça


se ( VETALT[C] <
MEDIATURMA ) então


imprima(VETALT[C]);

fim-se

fim-para

fim

1

Respostas

2014-04-25T14:22:50-03:00
#include <stdio.h>
main()
{

    int c, codSexo, nMulher;
    float altura, maior, menor;
    float vetAlt[50], vetSex[50];
    float somaMulher, mediaMulher;
    float somaTurma, mediaTurma;

    for( c=0; c<50; c++ )
    {
         printf("Altura: ");
         scanf("%f", &altura);
         printf("Cod. Sexo: ");
         scanf("%d", &codSexo);
         vetAlt[c] = altura;
         vetSex[c] = codSexo;
    }

    nMulher = 0;
    somaMulher = 0;
    somaTurma = 0;
    maior = vetAlt[0];
    menor = vetAlt[0];

    for( c=0; c<50; c++ )
    {
        if( vetAlt[c] > maior )
            maior = vetAlt[c];
        else
        {
            if( vetAlt[c] < menor )
            menor = vetAlt[c];
        }
        if( vetSex[c] == 2 )
        {
            nMulher++;
            somaMulher = somaMulher + vetAlt[c];
        }

        somaTurma = somaTurma + vetAlt[c];
    }

    mediaMulher = somaMulher / nMulher;
    mediaTurma = somaTurma / 50;

    printf("\nMaior altura da turma: %f", maior);
    printf("\nMenor altura da turma: %f", menor);

    printf("\nMulheres com altura acima da media das mulheres\n");

    for( c=0; c<50; c++ )
         if( (vetSex[c] == 2) && (vetAlt[c] > mediaMulher) )
              printf("%.2f\n", vetAlt[c]);


    printf("\nPessoas com altura abaixo da media\n");

    for( c=0; c<50; c++ )
         if( vetAlt[c] < mediaTurma )
             printf("%.2f\n", vetAlt[c]);

    printf("\n\n");
    system("pause");
}

1 4 1
vlw de novo cara vc ta ficando craque rsrs
kkk... de nada..rs