GALERA PRECISO CRIAR ALGORITMOS NO VISUALG PARA AMANHÃ AJUDA PFV

1)Uma equipe deseja calcular o número mínimo de litros de combustível, que
deve ser colocado no tanque de um carro de corrida, para que este possa
completar um determinado número de voltas em um circuito, até o primeiro
reabastecimento. Ler o comprimento da pista (em metros), o número total de
voltas a serem percorridas, o número de reabastecimentos desejados e o
consumo do carro (em Km/l). Em seguida, calcular e escrever o número
mínimo de litros necessários para completar as voltas até o primeiro
reabastecimento. Considerar que o número de voltas entre os
reabastecimentos é o mesmo.

2)
Uma revendedora de carros usados paga a seus vendedores um salário
fixo por mês, mais uma comissão, também fixa, para cada carro vendido e mais
5% do valor das vendas efetuadas por eles. Ler o número de carros vendidos
por um vendedor, o valor total de suas vendas, o salário fixo e o valor que ele
recebe por carro. Em seguida, calcular e escrever o salário mensal do
vendedor.

1

Respostas

  • Usuário do Brainly
2014-04-29T20:02:58-03:00
Algoritmo "abastecimentoF1"
var
pista, voltas, qtdAbastecimentos, consumo: inteiro
reabastecimento1, voltasParada1:real
inicio
escreva("Qual o comprimento da pista em metros?: ")
leia(pista)
escreva("Quantas voltas seram percorridas?: ")
leia(voltas)
escreva("Quantas vezes sera reabastecido?: ")
leia(qtdAbastecimentos)
escreva("Qual o consumo de conbustivel (km/L)?: ")
leia(consumo)
voltasParada1<-voltas/qtdAbastecimentos
reabastecimento1<-voltasParada1*pista
escreval("Total de combustivel ate o 1º reabastecimento",reabastecimento1," Litros")
fimalgoritmo

---------------------------------------------------------------------------------
Algoritmo "Revendedora"
var 
CarrosV :inteiro
//Carros vendidos
VtotaldeV, SalarioF, Valorporcarro,totalsalario:real
//Valor total de suas vendas, salario fixo e valor que recebe por carro
Inicio
Escreva ("Qual salário fixo ? " )
Leia (SalarioF)
escreva ("Qual número de carros vendidos?")
Leia CarrosV
Escreva ("Qual valor o funcionário recebera por carro ? ")
leia (Valorporcarro)
escreva ("Qual valor total de vendas ?")
leia (Vtotaldev)
Valorporcarro<-CarrosV*Valorporcarro
VtotaldeV<-VtotaldeV*0.5
totalsalario<-VtotaldeV+Valorporcarro+SalarioF
escreva totalsalario
fimalgoritmo


1 5 1
valeu! na segunda não entendi
não entendeu o que? criei variaveis com nomes aleatórios pq tava com preguiça de fazer tudo explicadinho dnv
Consertei, qualquer dúvida só falar