O que tem de errado com esse algoritmo? só esta aparecendo no (visual g) se a nota do aluno for menor que 5

escreva("informe a nota 1 :")leia(nota1)escreva("informe a nota 2 :")leia(nota2)escreva("informe a nota 3 :")leia(nota3)escreva("informe a nota 4 :")leia(nota4)media<-(nota1+nota2+nota3+nota4)/4se(media <=5)entaoescreva("voce sera reavaliado sua média:",media)se(media >5)entaoescreva("voce passou! sua média:",media)se(media >7)entaoescreva("voce é um ótimo aluno sua média:",media)fimsefimsefimse

1

Respostas

2014-05-06T17:18:57-03:00
Olá, falta colocar o "senao se", que tem de ficar em linhas separadas, senão dá erro.

var
nota1,nota2,nota3,nota4,media:real
inicio
escreva("informe a nota 1 :")
leia(nota1)
escreva("informe a nota 2 :")
leia(nota2)
escreva("informe a nota 3 :")
leia(nota3)
escreva("informe a nota 4 :")
leia(nota4)
media<-(nota1+nota2+nota3+nota4)/4
se(media <=5)entao
escreva("voce sera reavaliado sua média:",media)
senao
se(media >5)entao
escreva("voce passou! sua média:",media)
senao
se(media >7)entao
escreva("voce é um ótimo aluno sua média:",media)
fimse
fimse
fimse