Elabore algoritmo que contenha funções que solucionem os problemas abaixo. As funções devem estar agrupadas em um único algoritmo, dentro de um laço infinito que use a estrutura de controle <Enquanto> ou <Repita até>. Use a chamada as funções dentro da estrutura de controle < caso...de... escolha > utilize o comando pare para sair da estrutura de controle caso:

a. Determinar a área de um círculo conhecendo seu raio. Fórmula A = π * r² - em que r representa o raio do círculo.

b. Determinar o volume de um cone conhecendo-se os valores da altura e o do raio da base. Fórmula: V = 1/3 π r² . h em que h representa a altura e r representa o raio da base do cone.

c.Determinar a área de um Paralelogramo: Fórmula S = b * h - em que h representa a altura e b representa a medida da base do Paralelogramo.

d. Calcule a superfície de um losango: Fórmula S = d1*d2/2 em que d1 e d2 são diagonais do losango.

Se puderem me ajudar pra hoje, ficarei agradecida.....

1

Respostas

2013-06-20T11:39:26-03:00

algoritmo "semnome"
// Função :
// Autor :
// Data : 19/06/2013
// Seção de Declarações
var
resposta : caractere
funcao areacirculo : real
var
A, raio : real
inicio
leia(raio)
A<-pi*(raio*raio)
retorne A
fimfuncao
funcao volume : real
var
v,raio,h : real
inicio
leia(raio)
leia(h)
v<-(pi*(raio*raio)*h)/3
retorne V
fimfuncao
funcao paralelogramo : real
var
S,b,h : real
inicio
leia(b)
leia(h)
S<-b*h
retorne S
fimfuncao
funcao losango : real
var
d1,d2,S : real
inicio
leia(d1)
leia(d2)
S<-(d1*d2)/2
retorne S
fimfuncao
inicio
repita
leia(resposta)
escolha resposta
caso "A"
escreval(areacirculo)
caso "B"
escreval(volume)
caso "C"
escreval(paralelogramo)
caso "D"
escreval(losango)
caso "E"
interrompa
fimescolha
fimrepita
fimalgoritmo