Faça um programa em VISUALG que recebe 5
números inteiros e os armazena em um vetor X
de 5 posições. O programa deverá armazenar o
valor/2 de cada posição do vetor X em um
vetor Y. Após a substituição, escrever todo o
conteúdo dos vetores X e Y na tela;

1

Respostas

2014-06-09T00:11:57-03:00
algoritmo "exercicio"

var   X : vetor[1..5] de inteiro
      Y : vetor[1..5] de real
      i : inteiro
inicio

        para i de 1 ate 5 faca
             escreva(i,"º numero: ")
             leia(X[i])
             Y[i] <- X[i]/2
        fimpara

        escreval
        escreval("===== Vetor X ======")

        para i de 1 ate 5 faca
             escreval("X[",i,"] = ", X[i])
        fimpara

        escreval
        escreval("===== Vetor Y ======")

        para i de 1 ate 5 faca
             escreval("Y[",i,"] = ", Y[i])
        fimpara
fimalgoritmo

1 5 1