Alguem podeira me ajudar nessa porque eu nao consegui encontrar a resposta

O algoritmo abaixo tem como objetivo solicitar ao usuário que digite um número e em seguida mostra o sucessor deste número, entretanto, a linha 07 esta faltando à fórmula que é justamente para executar o solicitado. Sendo assim, assinale a alternativa que representa a solução correta para o algoritmo proposto.

01. Algoritmo “CalculaSucessor
”02. var
03. num, numseq: inteiro
04. Inicio
05. Escreva(“Digite um número: “)
06. Leia(num)
07.
08. Escreva(“O número sucessor ao que você digitou é “+numseq)
09. Fimalgoritmo

Escolha uma:
a. numseq := num + 10
b. numseq := num / 1
c. nuseq := num + 1
d. numseq := num + 1
e. numseq := (num /100) + 10

1

Respostas

2014-07-05T21:23:41-03:00
A correta é a letra D, numseq := num + 1.
Pois a variável numseq irá receber o valor da variável num e incrementar 1.
Exemplo: se o usuário digitar o número 3. Então a variável num irá receber o 3. E a variável numseq irá receber num + 1. Ou seja, 3 + 1.

num := 3

numseq := num + 1
numseq = 3 + 1
numseq = 4

Então o programa vai escrever o número 4, que é sucessor de 3.
:)


1 1 1