Fiz o seguinte algoritmo:
algoritmo "sem nome"
var
n1, n2, quociente: inteiro

inicio
escreva("Digite um valor para ser o dividendo: ")
leia(n1)
escreva("Digite um valor para ser o divisor: ")
leia(n2)
quociente <- n1\n2
se n2 = 0 entao
escreval(" DIVISÃO POR ZERO")
senao
escreval(" O quociente do primeiro pelo segundo é : ",quociente)

fimse
fimalgoritmo

Está tudo certo digito o valor 1 e 2 e o programa calcular o quiciente, porém quando eu digito 0 no valor 2 em vez do programa exibir a mensagem ''divisão por zero'', ele exibe a mensagem de erro ''Division by zero'', o que está errado? começou aparecer isso agora.

1

Respostas

A melhor resposta!
2014-07-11T19:09:57-03:00
Você deve colocar a variável quociente depois do SENAO...porque quando você coloca antes do SE, o programa visualg dará erro, travará e não executará o resto do código, pois a divisão por zero não existe.
Então o código ficará assim:

algoritmo "sem nome"
var
      n1, n2, quociente: inteiro
inicio
       escreva("Digite um valor para ser o dividendo: ")
       leia(n1)
       escreva("Digite um valor para ser o divisor: ")
       leia(n2)
       se n2 = 0 entao
          escreval(" DIVISÃO POR ZERO")
       senao
          quociente <- n1\n2
          escreval(" O quociente do primeiro pelo segundo é : ",quociente)
       fimse
fimalgoritmo

2 5 2