1) Faça um algoritmo que leia 30 valores para um vetor. Calcule
e escreva o somatório dos valores do vetor.
2) Escreva um algoritmo que leia um vetor de 20 posições; mostre
o vetor preenchido, e, em seguida, troque o primeiro elemento com o último, o
segundo com o penúltimo, o terceiro com o antepenúltimo e assim sucessivamente.
Mostre o novo vetor depois da troca.
3) Faça um algoritmo que leia uma matriz quadrada 4x4 de
valores inteiros, mostrando no final do algoritmo os seguintes dados:
a) A soma de cada uma das linhas.


b) A soma de cada uma das colunas.
c) A soma da diagonal principal.


d) A soma da diagonal secundária.

1
EU PRECISO DE AJUDA URGENTE COM ESTA TAREFA...OBRIGADA JA ANTECIPADAMENTE...BJUS

Respostas

2013-08-02T11:04:17-03:00
Resposta da 2 só

Algoritmo “Vetor de 20 Posições”
Declare vetor[1..20]:inteiro aux, i:inteiro
Inicio            
Para <- 1 ate 20 faca
                      
  Escreva (‘Valor’, i, ‘: ’)

  Leia(vetor[i])            
Fimpara
           
 Escreva(‘ Valores:’)
        
    Para <- 1 ate 20 faca
                      
    Escreva (‘Posições’, i, ‘: ’, vetor[i])
           
 Fimpara
          
  Para <- 1 ate 10 faca
           
 Aux<-vetor[i]

Vetor[i]<-vetor[21-i]
Vetor[21-i]<- aux
Fimpara            
 Escreva(‘Mostre Valores Invertidos’)

para i<- 1 ate 20 faca
 
escreva("Posições ",i,": ", vetor[i])
fimpara  
fimalgoritmo

olha no anexo é melhor
1 5 1