Preciso de um algoritmo pro VisuAlg que resolva equações do segundo grau!

1
Comentário foi eliminado
o meu visualg é a ultima versão
fiz esse algoritmo faz um bom tempo... vou ver se tenho ele aqui...
ta, se tiver me manda pro meu email o arquivo
não achei....tive que fazer de novo.

Respostas

A melhor resposta!
2014-08-07T20:07:14-03:00
Algoritmo "equacao_2_grau"

var delta, x1, x2, a, b, c : real

inicio
       escreva("Digite o valor de a: ")
       leia(a)
       escreva("Digite o valor de b: ")
       leia(b)
       escreva("Digite o valor de c: ")
       leia(c)
      
       delta <- ( b*b - 4*a*c )

       se delta < 0 entao
          escreva("Não existem raizes reais.")
       senao
          x1 <- (-b + raizq(delta))/2*a
          x2 <- (-b - raizq(delta))/2*a
          escreval
          escreval("Raizes:")
          escreval("X1 = ", x1)
          escreval("X2 = ", x2)
       fimse

fimalgoritmo

2 5 2
Lembra que esse algoritmo desconsidera raízes complexas, só resolve raízes no conjunto dos números reais. Blz. :)
ta certo,, vlw ai