Elabore um algoritmo com a utilização de um vetor de registro, com 30 posições com a descrição a seguir: "nome, salário, idade, altura".
O vetor deverá ser alimentado pelo usuário. No final, deverão ser
informados os dados do funcionário que tem o maior salário e a média de
todos os salários.

1

Respostas

2013-08-11T15:26:12-03:00
algoritimo: vetor30 
var vet : vetor[1..10] de inteiro vetpar : vetor[1..5] de inteiro vetimpar : vetor[1..5] de inteiro L ,J ,i , contpar , contimpar :inteiro inicio para i de 1 ate 30 faca escreval("digite um numero ") leia (vet[i]) fimpara contpar <- 1 contimpar <- 1 se ((vet[i] mod 2 ) = 0) entao vetpar[contpar] <- vet[i] contpar <- contpar + 1 se (contpar = 5 ) entao para J de 1 ate 5 faca escreval (vetpar[J]) fimpara contpar <- 1 fimse senao vetimpar[contimpar] <- vet[i] contimpar <- contimpar + 1 se (contimpar = 5 ) entao para L de 1 ate 5 faca escreval (vetimpar[L]) fimpara contimpar <- 1 fimse fimse
fim
 fimalgoritmo

1 1 1
Obrigado pela resposta! Ajudou bastante. ABÇS...