Respostas

2013-08-23T17:26:30-03:00
algoritmo "RetornaMaior"

var         
num, maior, cont: inteiro

inicio
maior:= -1000     
cont:= 0

enquanto cont < 5 faca     
escreva ("Digite o valor: ")     
leia (num)
se num > maior entao     
maior:= num     
fimse
cont:= cont + 1     
fimenquanto     
escreva ("O maior valor é: ", maior)
fimalgoritmo
Declare
alunos, dados: Registro // declaração do registro
nome:literal
código,media: inteiro
FimRegistro
NOTAS: arquivo do tipo dados // criação do arquivo do tipo de dados que contém o registro.
Inicio
Abra(NOTAS) // Abertura do arquivo
Enquanto (FDA(NOTAS) <> 1) faca // teste se final do arquivo
Avance(NOTAS) // percorre o arquivo, ou seja, avança para o próximo registro
Fimenquanto
Feche(NOTAS) // fecha o arquivo
fimalgoritmo